Last Shout - Posted by: Bernie - Sep. 09, 2020, 04:40:16 PM
WTF is up NW?!!!! ;D

Author Topic: Bug Report: FFDSHOW incompatibility  (Read 2897 times)

0 Members and 1 Guest are viewing this topic.

Offline Negi

  • Hapless Fledgling
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Bug Report: FFDSHOW incompatibility
« on: Jan. 25, 2007, 08:04:17 PM »
Hey there, Ys Fans.  If you've been having some trouble starting The Oath in Felghana where your screen blacks out and you need to reboot, you're suffering from a very specific issue due to incompatibility with FFDSHOW's mpeg1 decoder speedup tricks. 

The remedy for this is to go into your FFDSHOW video decoder settings and under Info and Debug and add YSF_Win.exe and YSF_Win_DX9.exe  to the little box marked "don't use FFDSHOW in." 

This bug has nothing to do with Nightwolve's patch and is a problem with either FFDSHOW or Falcom. 

By the way, Thanks, Nightwolve, for helping me resolve this issue

Offline NightWolve

  • Administrator
  • Distinguished Shogun
  • *****
  • Posts: 865
  • Karma: +132/-0
  • Gender: Male
    • View Profile
    • Ys Utopia.net
Re: Bug Report: FFDSHOW incompatibility
« Reply #1 on: Jan. 25, 2007, 08:07:02 PM »
I was about to post in your short-lived prior thread to say that if it's a matter of adding some registry keys to disable ffdshow for YsF, I might be willing to do it, so you may provide them.


You break my record, now I break you, like I break your friend!

Offline Negi

  • Hapless Fledgling
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Bug Report: FFDSHOW incompatibility
« Reply #2 on: Jan. 25, 2007, 08:12:56 PM »
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\GNU\ffdshow]
"blacklist"="explorer.exe;oblivion.exe;ysf_win.exe;ysf_win_dx9.exe;YS1_WIN.EXE;YS2_WIN.EXE"

That's the text from my regfile.  This same entry may appear in HKLM because FFDSHOW has optional per user settings.  I'm not too familiar with NSIS, but it might be smart to append those values rather than overwriting someone's blacklist. 

By the way, I've confirmed that setting this works on three computers. 
Also, thanks for your hard work!